就是愛尚生活 - 94i3 Life

 找回密碼
 免費註册

人氣: 16109|回復: 65

ECShop 2.7.3 php 5.5 UTF8_TC 修改版

    [複製鏈接]
字體大小: 正常 放大

新浪微博達人勛

總積分排名︰1
簽到
2042
鮮花(66) 雞蛋(2)
累計在線
324304分鐘
發表於 2014-5-13 18:07:20 | 顯示全部樓層 |閱讀模式
  
ECShop 2.7.3 php 5.5  UTF8_TC 修改版

資源大小:7.15MB

本修改版可在Apache 2.4 和php 5.5 上運行。

由於我只在我的機器上測試過,在你的機器上可能還存在部分問題,歡迎大家跟我聯繫互相學習^^

下載:
遊客,如果您要查看本帖隱藏內容請回覆
官方版本的ecshop對php新版本兼容不是特別友好,一些細節問題.用了一點時間修復,更新如下.
  1:類初始方法重疊問題.
  2:引用問題.
  3:模板解析/e的問題.
  4:函數調用細節問題. 此版本是支持管理員使用普通密碼的,如admin,僅做了兼容處理,其它代碼都未修改流程.

下載地址V2 :
遊客,如果您要查看本帖隱藏內容請回覆

php 5.5 : http://94i3.tw/php55ecshop/
遊客,如果您要查看本帖隱藏內容請回覆
官方測試版 :
遊客,如果您要查看本帖隱藏內容請回覆
ECShop_V2.7.3_UTF8_release0704_yuan.zip (7.91 MB)
修復後台導航雲服務中心沒顯示問題.
加入站點日誌,數據庫管理功能.
修復一些細節問題.兼容php5.5 php 5.6等新環境.
修復所有php異常語法.   
兼容簡單管理員賬號密碼安裝.   
兼容IE11下後台編輯器加載問題.   
其它相關修正.PHP5.4以上安裝ECShop出錯解決方案


就是愛尚生活 - 94i3Life - 歡迎您 加入 !

回復 鮮花(66) 雞蛋(2)論壇版權

使用道具 舉報

新浪微博達人勛

鮮花(1) 雞蛋(0)
累計在線
324304分鐘
發表於 2015-4-30 15:00:52 | 顯示全部樓層

我好久終於找到能兼容PHP5.5的ECSHOP,而且還是繁體中文
版主您為了能夠讓ECSHOP在PHP5.5版本的伺服器上正常執行而不出現錯誤,花了不少時間再修改
您辛苦了!!

鮮花雞蛋

迪史克斯  在2015-4-30 05:51 PM  送朵鮮花  並說:我非常同意你的觀點,送朵鮮花鼓勵一下

就是愛尚生活 - 94i3Life - 歡迎您 加入 !

新浪微博達人勛

鮮花(1) 雞蛋(0)
累計在線
1526分鐘
發表於 2015-4-15 18:10:54 | 顯示全部樓層
一直有PHP版本過高的問題 趕快下載來修正 不然用到快抓狂

鮮花雞蛋

迪史克斯  在2015-4-15 06:50 PM  送朵鮮花  並說:我非常同意你的觀點,送朵鮮花鼓勵一下

就是愛尚生活 - 94i3Life - 歡迎您 加入 !

新浪微博達人勛

鮮花(1) 雞蛋(0)
累計在線
324304分鐘
發表於 2015-1-22 16:50:18 | 顯示全部樓層
很需要這個修正檔

鮮花雞蛋

迪史克斯  在2015-1-22 05:03 PM  送朵鮮花  並說:我非常同意你的觀點,送朵鮮花鼓勵一下

就是愛尚生活 - 94i3Life - 歡迎您 加入 !

新浪微博達人勛

總積分排名︰1
鮮花(66) 雞蛋(2)
累計在線
20分鐘
發表於 2014-5-13 18:21:18 | 顯示全部樓層
ECShop_V2.7.3_UTF8_release0411 0.jpg

服务器端运行环境推荐
php版本5.0及以上
Mysql版本5.0及以上
空间安装zend
空间支持文件锁功能
开启GD功能
Mysql函数支持mbstring、iconv、fsockopen

管理后台运行浏览器推荐
Firefox、IE7+、Safari、Chrome

1.jpg ecshop最全補丁包(2013.12.06最新補丁已更新)

sxdfgn65.PNG
ECShop 2.7.3 php 5.5 UTF8_TC 修改版 http://94i3.tw/shop/

就是愛尚生活 - 94i3Life - 歡迎您 加入 !

新浪微博達人勛

總積分排名︰40
鮮花(1) 雞蛋(0)
累計在線
10分鐘
發表於 2014-5-14 09:22:33 | 顯示全部樓層

就是愛尚生活 - 94i3Life - 歡迎您 加入 !

新浪微博達人勛

總積分排名︰1
鮮花(66) 雞蛋(2)
累計在線
324304分鐘
發表於 2014-5-14 10:34:27 | 顯示全部樓層


PHP5安裝ECShop出錯解決方案

因為官方版版本只限於php 5.3以下, 會比較適合安裝^^

服务器端运行环境推荐
·php版本5.0以上~5.3以下的版本(推荐使用5.2系列版本)
·Mysql版本5.0及以上

·空间安装zend
·空间支持文件锁功能
·开启GD功能
·Mysql函数支持mbstring、iconv、fsockopen

就是愛尚生活 - 94i3Life - 歡迎您 加入 !

新浪微博達人勛

鮮花(0) 雞蛋(0)
累計在線
10分鐘
發表於 2014-6-10 16:12:23 | 顯示全部樓層
php5.5 的問題好像很久了,ecshop公司一直沒更新

來測試看看這個是否可以使用,感謝分享

就是愛尚生活 - 94i3Life - 歡迎您 加入 !

新浪微博達人勛

總積分排名︰1
鮮花(66) 雞蛋(2)
累計在線
15分鐘
發表於 2014-6-10 16:15:21 | 顯示全部樓層

就是愛尚生活 - 94i3Life - 歡迎您 加入 !

新浪微博達人勛

鮮花(0) 雞蛋(0)
累計在線
5分鐘
發表於 2014-6-17 11:27:17 | 顯示全部樓層
不知到在群暉DSM5.0系統上能否正確運行,
我來測試測試,感謝分享

就是愛尚生活 - 94i3Life - 歡迎您 加入 !

您需要登錄後才可以回帖 登錄 | 免費註册 | 新浪微博登陸

本版積分規則


快速回復 返回列表 聯繫我們 搜索

QQ|關于我們|聯絡我們|就是愛尚生活 - 94i3 Life |簡體中文

GMT+8, 2018-4-23 04:18 AM

Powered by 就是愛尚 - 94i3.tw - X3.2

© 2007-2018 愛上誠信。愛上精緻。愛上專業。愛上時尚。愛上分享

94i3就是愛尚是一個經驗分享平台,網友均可以在94i3免費互相學習別人分享之經驗。
※本站只提供空間,網友自由發表使用,也請會員網友尊重論壇規則論壇注意事項,本網站內容均從網路上收集或網友們提供,其內容及言論的完整性以及正確性並不代表本站立場,本站不負任何法律責任,均與本站無關。倘若文章、圖片或是內容言論等有任何問題,請聯絡我們,我們將會第一時間優先處理或刪除。

快速回復 返回頂部 返回列表